Hello, Here is a guide to assist check the fuse with the fuse panel identification and also locations below: https://www.cg-tower.com/articles/how-to-check-a-car-fuseCheck the end the diagrams (below). Please let us understand if you require anything else to acquire the difficulty fixed.


You are watching: 2001 chrysler town and country fuse box location

*

*

*

*

*



See more: (Get A Green Plant Can Perform Photosynthesis If Given Nothing More Than

yes so i willl start by saying ns know about as much as the mean joe about cars and also will handle minor repair as lengthy as there isnt a chance of me screwing anything up worse.So to obtain the the point, my wife left for work-related in the van and also quickly turned roughly because it was stuttering/skipping and also low top top power, certainly didnt feeling right. Ns jumped in it and verified that was definitely idling and running rough.Ive had actually the van because that 3 years and also put a many miles top top it and also never adjusted the plugs so ns figured i'd begin with this due to the fact that it necessary it anyways. Readjusted the plugs, cranked the van ago up, drove it, instance was slightly far better but still not right, stuttering etc.Next action was to inspect the wires, i pulled the end my multimeter to check for resistance but because I could not discover what an acceptable reading would it is in online, i figured I'd go ahead and also get a collection since it probably needed that as well. Autozone had actually a coil load for 45 bucks so ns picked that up too, figured it was cheap enough to go ahead and also knock out that possibility too.Pulled turn off the old coil pack and wires, popped the new ones on, linked everything back as it was before. Basic enough. Well* top top trying come crank the valve I acquire a quick clicking noise that appears to it is in comming native the ASD relay in the fuse panel. Weirdly enough it still clicks after pulling the crucial out of the ignition, I have to remove the an adverse batt cable to stop it. Rechecked all my connections, every little thing is solidly in place and where it need to be. Make the efforts reconnecting the old wires/coil pack because at the very least then I might start the van, but now I have the same trouble with that setup. As much as I have the right to tell, the system isnt even going as much as the coil pack since I obtain the exact same clicking noise with no harness connected to the coil pack.I am at a loss, dont have actually a ton of money come dump it off at a dealership or somthing to fix a significant electrical difficulty so ns figured I'd check here first to watch if anyone has any idea what i have screwed up?Thanks in advance for any assist offered